nmolnar

ExportMetadata_conversion does not work in ArcGIS Server 10.1

Discussion created by nmolnar on Oct 2, 2013
When I try to use the ExportMetadata_conversion function via arcpy in a processing script on Server (Linux), I get the following error: ExecuteError: Failed to execute. Parameters are not valid. ERROR 000816: The tool is not valid. Failed to execute (ExportMetadata).

This appears to be related to this long-standing issue: http://forums.arcgis.com/threads/74468-Python-Errors-in-IDLE-when-processing-metadata

However, the workaround mentioned in that thread won't work here because 1) I can't install Desktop on linux to get the DLLs, and 2) If I copy the DLLs from Desktop elsewhere, they'd be 32-bit and Server is now 64-bit only (right?)

Any other ideas for a workaround? Is this issue actually fixed in 10.2? Will it ever be fixed?

Thanks,
_Nik

Outcomes