smarotta

Very simple ArcMap add-in freezes

Discussion created by smarotta on Sep 25, 2013
Latest reply on Sep 26, 2013 by smarotta
I'm working with ArcMap add-ins for the first time, and I'm having some trouble with it. I tried looking up the problem I'm having and I can't seem to find anything that mentions it. I just wrote a very, very simple ArcMap add-in. All it does is pop up a simple "Hello World" dialog box, per the example in the ArcGIS documentation. I've got a command, or "button", created, and I've got the button contained in a toolbar. When I open ArcMap, the toolbar shows up, the button shows up, and when I press the button, the whole ArcMap application hangs. When I try to debug the code, I see that it's successfully entering the "onClick" method, but when I try to execute the showDialog, the whole ArcMap application hangs. I tried replacing it with a simple println and I got the same thing.

Okay, I just tried something else, and now I'm completely confused. I tried one more thing, where I had a few lines of code to just create a variable and toss it around a bit. I took out the showdialog and kept the println. I copied the new add-in to the ArcMap add-ins directory. Now when I click the button, I get the dialog box that an OLDER version of the add-in had, and it doesn't freeze anymore. It's running an older version of the add-in, but I have no idea where it's getting that version because the version I've got in there doesn't have that code anymore.

If this sounds familiar to anyone, please enlighten me!

Outcomes