allen_anselmo

Pre-3.0 API and Latest Chrome

Discussion created by allen_anselmo on Aug 22, 2013
Latest reply on Sep 3, 2013 by DSwingley-esristaff
Hey all,

Not sure how much this affects any of you, but I thought I'd post it either way to get the information out there. It seems that the latest version of Chrome (29.0.1547.57 m) that came out Tuesday or so, has made some change which causes pages with older ESRI Javascript API versions (pre-3.0) to fail to load due to some sort of errors being triggered in the contenPane loading code of dojo it seems.

It doesn't seem to be affecting our pages that are more up to date (3.5+) but we have some older ones in production which lock up entirely on load in Chrome now and weren't doing so last week, whereas they load fine in the latest Firefox and IE browsers.

Anyone else running into this situation or even have any older pages in production that haven't gotten upgraded?

If so, be sure to put in a bug report to Chrome through the Menu > Tools > Report an Issue tool, since the more they get in, the more likely they are to fix whatever they broke so abruptly.

Outcomes