schmedly

python 27 with 64bit server not working after sp1

Discussion created by schmedly on Jul 23, 2013
Latest reply on Jul 24, 2013 by schmedly
I have mulitply .py scripts to process and update data on my server.  However, for this discussion I'm limiting it to a simple script.

My python script uses to function   arcpy.MakeQueryTable_management   to create a queryTable.  Prior to sp1, when I ran it at the command line (via batch file) I had to run it as .... "C:\Python27\ArcGIS10.1\python.exe" "...path\pythonScript.py" and everything ran fine.


1.  Now if I run this I get the following:   "....python.exe cannot start or run due to incompatibilty with 64-bit versions of Windows...."

2.  So I change the path to run as ... "C:\Python27\ArcGISx6410.1\python.exe" "...path\pythonScript.py" and the command line recognizes it and starts to run.  However, when the python script begins I get various errors and warnings.

......ERROR 000732: Input Rows: Dataset Database Connections\..... does not exist or is not supported

3.  However, if I run the python script directly from IDLE there are no errors and everything is fine.

4.  I can change the command path to run as ... "C:\Python27\ArcGIS10.1\pythonw.exe" "...path\pythonScript.py"... NOTE pythonw.exe  NOT python.exe
    The script will run, but there is no incorporated feedback from Python script  to the dos prompt.


What has happened and how to fix it????  The python script acts as if it needs to run via 64bit, but then doesn't recognize the arcpy functions.

thanx,
Eddie

Outcomes