jvseagle-co-nz-esridist

ArcGIS for Server 10.1/Desktop Web Adaptor for IIS Issue

Discussion created by jvseagle-co-nz-esridist Employee on Jul 2, 2013
Latest reply on Jul 5, 2013 by bubbahey25
Hi,

Just found out an odd behaviour of ArcGIS 10.1.

My install (Development Environment):
- ArcGIS for Server 10.1 SP1
- Authentication: Windows (Web Tier)
- Web Adaptor for IIS (administrative access enabled)

I have tried to setup the GIS Server admin connection in ArcGIS for Desktop using the Web Adaptor URL and noticed that it rejects that URL and replaces for the GIS Server site URL running on port 6080.

Monitoring the requests that have been made I have noticed that ArcGIS for Desktop attempts to use the Web Adaptor URL, verifies that it has SSL enabled (???) and tries to invoke the generateToken method using HTTPS which is obviously denied since this is a dev environment and does not have the certificate installed.

I actually haven't enabled SSL on the Web Adaptor. It just inherited the Default Web Site properties ... which did support HTTPS.

Because he couldn't connect using HTTPS, ArcGIS for Desktop changes the request to the AGS Server site running on port 6080 and verifies that it works and ignores my setting. This means that anyone using that connection will go directly to the AGS site instead of the Web Adaptor.

I have removed the SSL support on the Web Adaptor and ArcGIS for Desktop allowed me to change the connection ... finally. Without closing ArcGIS for Desktop I just enabled again the SSL and noticed that ArcGIS for Desktop allowed me to change it again ... odd. I have closed ArcGIS for Desktop and opened it again and tried to change the connection and it started working as previously and ignoring my settings.

Not sure if this is an intended behaviour but is quite odd and took some time to figure out. Maybe ArcGIS for Desktop shouldn't be accepting the connection in first place if it considers it invalid? Instead of trying to guess and change it to something that I don't want and without telling me that an issue occured?

It is a bit odd testing whether the Web Adaptor supports SSL or not and if it does assume that the GIS server site also supports ... these are separe components ...

Hope 10.2 does not have similar behaviour.

Cheers,
Jose




 








Because it is a development environment I haven't configured an SSL certificate on the AGS server site.

Outcomes