Problems with publishing a service multiple layers

Discussion created by dgueclue on Jun 20, 2013
Latest reply on Jun 20, 2013 by dgueclue
Hi guys!

I've the following setup:
-ArcGIS Server 10.1 and ArcGIS Desktop 10.1 both installed on the same machine (Windows Server 2008).
- A network-share which i use as my central storage

My goal:
- To publish a service by using ArcMap.

What I've done:
- I gave to the ArcGISServer-User all permissions on the network-share
- Registered the folder/share
- Added 2 Layers (from *.gdb) to ArcMap
- Tried to share as service but got the following error: "Packaging succeded but publishing failed"
- Tried another way: Created an .sd file and uploaded the file to the Server. This worked but only one Label is published in the service. When I look into the logfile of the service I can see the following error/warning: Code 10801 - The Layer "Layer2" is invalid.
If I try to publish only Layer2 by using a .sd file it works fine. But i need both Layers in one Service.

Can anyone help me?

Thank you,