bbehling

Geoprocessor and Versioned Data

Discussion created by bbehling on May 29, 2013
Latest reply on Jun 13, 2013 by bbehling
I'm trying to use the Append class on a versioned workspace and the Geoprocessor class throws an error:

"Parameters are not valid.
ERROR 000732: Target Dataset: Dataset \DBO.dataset\.DBO.featrueclass does not exist or is not supported
Failed to execute"

Simple two lines of code:

Append append = new Append(selectFGDB.out_layer_or_view, featureClassSDEVersion);
append.schema_type = "NO_TEST";

If I change the above code to use a feature class from a non-versioned workspace, then the append tool works fine.

Seeing this bug here:
http://support.esri.com/es/knowledgebase/techarticles/detail/38239

I'm wondering if this has been resolved in 10.1?

Also have the same problem with the MakeFeatureLayer class, but In ArcMap, the Make Feature Layer tool works fine on versioned
data.

Outcomes