dblauvelt

Time-enabled/ Statistics to 'Current Display Extent' Issue

Discussion created by dblauvelt on May 21, 2013
I'm trying to time-enable a series of images (NTFs) with 10.0 and having an issue being able to see the images as anything other than black.

I've created individual source mosaics for each year of imagery, and build overviews and calc'd statistics, and these look great. I've then been able to combine them into another mosaic dataset (a derived mosaic) using the Table raster type... and additionally had to calc over the _MaxPS and _MinPS and _Cat values that aren't carried across; additionally, I'd created the Year field and set the Start/End Time Field in Properties. Using the time-slider, the foot prints and images turn on/off properly. But both this mosaic, and if I create a Reference Mosaic, the images are simply black.

They become visible in ArcMap if I set Statistics to 'Current Display Extent', however, I don't want the user to have to do this in a viewer. Since the individual images have already had their statistics caculated (and had their overviews successfully generated) in their respective year mosaic before being loaded into the multiyear mosaic, I don't understand why they don't simply display. 
Instead of loading into a mosaic as Table format, I have also tried loading them simply as the default type Raster, but this has the same issue.

Has anyone else run into this/is there a solution, or perhaps a function I could use on the properties of the mosaic itself to calc statistics from the current extent? In the past I have gotten around this by adding the mosaic to arcmap setting the Statistics to 'Current Display Extent' and saving it as a .lyr file that I then published, but this severely impacted the service (took up to 10-20 seconds to display in a flex viewer).

Any help would be appreciated!

Outcomes