gbushek

Standardize Address in 10.0

Discussion created by gbushek on May 20, 2013
Latest reply on Aug 19, 2013 by davidclarke
I have some old code from 9.2 that tries to standardize an address stored in the database before trying to geocode that address.  The capability to call StandardAddress on the GeocdeServer object is no longer available.  I've tried numerous routes to standardize in 10.0 but everything leads to a dead end.  Is there a simple way to standardize an address in 10.0? 

Ive tried the following

    - ArcObjects
           can't get locator style using GetLocatorWorkspaceFromPath("") and GetLocatorStyle(US Address - Dual Ranges"). Returns an error that a locator by that name does not exist.

    - Geoprocessing Tool
           requires the address to be stored in a table/featureclass.  I just have a string. and don't want to go through everything involved in writing that value to a table and reading the new standardized address from a table.

    - Rest service
           no call to standardize address available


Thanks, Gary

Outcomes