AnsweredAssumed Answered

Feature Outline Masks tool not working in geoprocessing service ArcGIS 10.1

Question asked by crdale on May 16, 2013
Latest reply on May 21, 2013 by crdale
I have a Python toolbox custom tool that exports maps from a template MXD, and one of the geoprocessing tools I'm using in the custom tool is Feature Outline Masks.  This tool only works at the ArcGIS Desktop Advanced license level.  When I run it in Desktop with this license, the tool works as desired.  We want to use this as a georpocessing service, and got it to publish successfully.  Yet, when I run the service, the tool fails at Feature Outline Masks because it says that the tool is not licensed.  Our ArcGIS 10.1 Server has Desktop installed on it and the license level is set to Advanced.  I've also put the "import arcinfo" statement in my script, but that doesn't seem to make a different.  In the script, I check to see if an Advanced license is available, and I get no complaints back from the tool.  The "SetProduct" function is a legacy function, so that won't work.

Any tips?  What am I missing?  Is our Desktop install on the server conflicting with the licensing?

Outcomes