xiannian

ArcSDE 10.1 service, esri_sde, creation failed

Discussion created by xiannian on May 7, 2013
Latest reply on May 8, 2013 by asarkaresrisa-esridist
Hi, friends,

I am doing MS SQL Server (2012 version) based ArcSDE (10.1). I followed the installation guide to do create and start the service. But when I started the service, it is always failed. No matter what I do, I always get the error message of "The ArcSDE Service (esri_sde) service on Local Computer started and then stopped. Some services stop automatically if they are not in use by other services or programs".

Since I am following the installation guide and I want to create the service on the local server machine, I want to ask experts questions based on the steps.

1. for creating the service, I use the default service name, which is esri_sde. My machine name is TEST1, and the SQL Server instance name is: MSSQLSERVER.
In the sample command line: sdeservice -o create -d SQLSERVER,MYSERVER\SSINSTANCE -i sdesvc -p keepout
For the d parameter, if I use TEST1\MSSQLSERVER, it gives me the error message: Database service MSSQL$MSSQLSERVER does not exist. Use option -n to exclude MSSQL$MSSQLSERVER from ArcSDE dependent service..
If I use only machine name, it works.
For me, the working command line is: sdeservice -o create -d SQLSERVER,CATEVAC2 -p keepout.

2. for register operation of ADMIN_DATABASE , the sample command is:
sdeservice -o register -d SQLSERVER,MYSERVER\SSINSTANCE -r ADMIN_DATABASE -v mygdb
In my case, I changed MYSERVER\SSINSTANCE to TEST1.
My questions are: what is ADMIN_DATABASE?
How to set it? There is no database mygdb in the instance.
Should this database pre-exist? I created a sde database by using the Database Management Studio, and I changed "mygdb" to "sde".
So, in my case, the register database opertion command line is:
sdeservice -o register -d SQLSERVER,TEST1 -r ADMIN_DATABASE -v sde

3. for register operation of SDE_DBA_USER, the sample command is:
sdeservice -o register -d SQLSERVER,MYSERVER\SSINSTANCE -r SDE_DBA_USER -v "localhost\network service" -i sdesvc
I changed MYSERVER\SSINSTANCE to TEST1 and removed -i sdesvc since I want to use the default service name. So, my working verion of command line is:
sdeservice -o modify -d SQLSERVER,TEST1 -r SDE_DBA_USER -v "localhost\network service"


In my case, three commands were executed successfully. But when I tried to start up the esri_sde, I got error messages as I mentioned before.

Any else setting that I left out?

Thanks for any help.

-Mike

Outcomes