truongpm

Deploy geoprocessing custom tool to arcgis server 9.3

Discussion created by truongpm on Apr 4, 2013
Hi everyone,
I developed custom geoprocessing tool on arcgis 9.3.1 products.
I had installed arcgis desktop (arc catalog and arcmap) 9.3; arcengine; arcobject; and arcgis server 9.3.1 on my desktop computer.
For now, i success on custom tool which can run on arcmap. But when i build the model and publish it (tool and model that use this tool) to arcgis server, it get error when execute this model. Error log show: 'ERROR 000816: The tool is not valid.'
I had search on internet i found some dicussion about this error:
    http://gis.stackexchange.com/questions/19268/is-it-possible-to-publish-a-geoprocessing-services-that-uses-a-custom-gptool-on
    http://forums.arcgis.com/threads/16614-Add-Custom-GP-Tool-to-Toolbox
Folowing that dicussions, i have try
1. Build my custom tool to asembly with strong name
2. Register custom tool to arcgis (in here i wonder which arcgis product) - folowing this page: http://resources.esri.com/help/9.3/arcgisengine/dotnet/9826f81b-278c-49cc-a912-ab8d86f5e91e.htm
The command i usee is:
    regasm EditTools.dll /codebase

The result is: C:\Windows\Microsoft.NET\Framework\v2.0.50727>RegAsm.exe C:\Users\Administrator\
Downloads\GPConvexHullTool\CSharp\GP_DGNToSDE\bin\Debug\GP_DGNToSDE.dll /codebas
e
Microsoft (R) .NET Framework Assembly Registration Utility 2.0.50727.5420
Copyright (C) Microsoft Corporation 1998-2004.  All rights reserved.
Types registered successfully

When i finished two step, i re-publish new map service but get the same error: ERROR 000816: The tool is not valid.
It seem that i can not register with arcgis.

My question is how to fix this bug?
Another question is when i use the command "regasm EditTools.dll /codebase", which product of arcgis i register for my 'EditTools.dll'?

Thanks.

Outcomes