AnsweredAssumed Answered

Issues with input feature class when uploading a geoprocessing tool to server

Question asked by paulsteeves2011 on Mar 8, 2013
Latest reply on Mar 21, 2013 by slin-esristaff

Long time fan, first time poster. I am building a number of geoprocessing tools using model builder, and then publishing them as services on arcGIS for server. I then have been using the rest URL for these services to run geoprocessing tools in flex viewer. So far it has been successful with one exception. When I created my geoprocessing tool via model builder in arcGIS for desktop 10.1, I was able to create parameters that allowed me to select a number of input feature classes. Each feature class has a different set of values, and I was able to create a parameter so that a user would be able to select the feature class, and then the corresponding values for that feature class. For example, one model extracts data from a layer, and then exports it as an ascii file. This all works fine on desktop, however when I publish the tool as a service, it only keeps the feature class that was selected when I ran the tool in arcgis for desktop. When I examine the REST services directory for this new service tool, I notice that it only references the layer selected when the tool was run. The rest of the data has been included, but is not being referenced as a potential set of values. To make a long story shorter, when I create a geoprocessing tool in flex viewer, I can scroll through the different input features, however it will only ever let me select the value fields corresponding to that one input feature class. I've tried playing around with the parameters, and have also just uploaded the "export feature attribute to ascii" tool provided in the arcgis desktop toolbox, however get the same result. Am I missing something, or is this an unfortunate limitation of uploading services to arcGIS server?

Thanks very much!