iggz

Why can't I access my web server externally?

Discussion created by iggz on Mar 1, 2013
Latest reply on Apr 2, 2013 by bubbahey25
I'm trying to access my GIS server from outside my network, but I'm having trouble and I'm not sure what's wrong.

I have a Windows 2012 Server x64 with SQL Server 2012.
I'm using IIS 8 as a web server on the same machine.
I've installed ArcGIS for Server 10.1 SP1 and ArcSDE 10.1 also on the same machine.
I've also installed the Web Adapter 10.1 SP1.

I configured the Web Adapter's GIS Server URL to-
http://(My Server's Internal IP):6080

And when I hit configure the Web Adapter returned-
Status: The following GIS servers are registered to your Web Adaptor
(My Server's Name)

The firewall on the server is currently shut off.
And port 80 on the router has been forwarded to the server internal IP.

I want to be able to access the rest services off network via-
http://(My Server's External IP)/arcgis/rest/services

And I want to be able to access the default website via-
http://(My Server's External IP)

Now when I'm connected to the network, I'm able to type the external IP and it connects me to the default website within IIS, and I'm able to view the rest services.

But if I'm off the network and access it externally from the external IP, I'm sent to the login page of the router on the internal network! What could be doing this? Am I not fowarding the ports correctly?

Are there certain parameters/permissions inside IIS that I need to set for the Web Adapter?

What am I missing?

Thanks.

Outcomes