cyrilcherian

"Deferred object is missing" error when calling GP SubmitJob

Discussion created by cyrilcherian on Feb 14, 2013
Latest reply on Feb 21, 2013 by hbostic
I appreciate any help on this. I am trying to Submit a geoprocessing job where I have five featureset parameters. I have added Proxy url to my page and also configured the proxy server.
The last two featureset parameters have around 15 records each with around 4 columns in each of them. When I pass all parameters, I get the error "Deferred Object is missing". I checked in Fidller and no request is being send to the server.
As a test, I tried passing parameter one at a time. Now I can see the request is correctly send to the server and I get validation errors because some of the parameters are missing.

First three featureset parameters only have around two rows in it. Adding the first three parameters is sending request to the server.
When include the 4th parameter into the request I get the above error. I guess it is something to do with the size of the request string. Even though I have the proxy set up, I don't see any POST message being created when the size exceeds 2K characters.

I tried some dojo.Deferred examples and still have the issue.

Looking for some examples using dojo.Deferred in GP SubmitJob and Execute jobs.

Thanks
Cyril

Outcomes