mstarr

SDE Table Registry

Discussion created by mstarr on Jan 21, 2013
Latest reply on Jan 22, 2013 by mstarr
Greetings,

I have a geometric network (junctions) that seems to be stuck in the sde.table_registry.   This is keeping me from using the same name of the geometric network which I have since deleted.  the new network must have the same name based on various customizations and other schedulded tasks.

steps I performed
1aDelete all versions, compress
1b. delete geometric nework
2 disable archiving
3 unregister as versioned
4 recreate geometric network...  error  [ORA-20218: Registration 11116 already exists][TABLEOWNER.GasNetwork_junctions]

the SDE geodatabase on Oracle 11g

The featuredataset in which this geometric network had existed did have archiving enabled so the geometricnetwork_junctions_H table is also stuck in the registry.  If I run the command:

          sdetable -o describe_reg -U tableowner .... 

these two tables are listed in the sde registry.  However when I run

         sdetable -o describe_reg -t tablename.....

these two tables are not found.

How do I remove the registry entries?

I have recreated a geometric network with a different name so I am convinced this is the problem.

Thanks in advance

Matt Starr

Outcomes