tovey15

Export Topology Errors in Model NOT WORKING as Parameter

Discussion created by tovey15 on Jan 17, 2013
I have been trying to build a model that will let me change the enviornment for data analysis and one of the steps I have is to do a topology analysis on some polygon data. When I set the model up and hard code (double click and enter) the information inside the edit function of the process, it does exactly what it is supposed to do. BUT when I set the output location as a varaible and try and change the location - nothing shows up anywhere. The geoprocessor shows that it has completed without error. Is this a bug? Has anyone else ran across this?

Here is what the geoprocessor gives me:

Executing: Model1222 C:\ClientData\Working\TestData\Test.gdb\FireRDs_Topo C:\ClientData\Working\TestData\Test.gdb\FireRDs_Topo\FireRDs C:\ClientData\Working\TestData\Test.gdb\FireRDs_Topo
Start Time: Thu Jan 17 15:51:31 2013
Executing (Create Topology): CreateTopology C:\ClientData\Working\TestData\Test.gdb\FireRDs_Topo FireRDs_Topology #
Start Time: Thu Jan 17 15:51:31 2013
Executing CreateTopology...
Succeeded at Thu Jan 17 15:51:31 2013 (Elapsed Time: 0.00 seconds)
Executing (Add Feature Class To Topology): AddFeatureClassToTopology C:\ClientData\Working\TestData\Test.gdb\FireRDs_Topo\FireRDs_Topology C:\ClientData\Working\TestData\Test.gdb\FireRDs_Topo\FireRDs 1 1
Start Time: Thu Jan 17 15:51:31 2013
Succeeded at Thu Jan 17 15:51:33 2013 (Elapsed Time: 2.00 seconds)
Executing (Add Rule To Topology): AddRuleToTopology C:\ClientData\Working\TestData\Test.gdb\FireRDs_Topo\FireRDs_Topology "Must Not Have Gaps (Area)" C:\ClientData\Working\TestData\Test.gdb\FireRDs_Topo\FireRDs # # #
Start Time: Thu Jan 17 15:51:33 2013
Succeeded at Thu Jan 17 15:51:34 2013 (Elapsed Time: 1.00 seconds)
Executing (Add Rule To Topology (2)): AddRuleToTopology C:\ClientData\Working\TestData\Test.gdb\FireRDs_Topo\FireRDs_Topology "Must Not Overlap (Area)" C:\ClientData\Working\TestData\Test.gdb\FireRDs_Topo\FireRDs # # #
Start Time: Thu Jan 17 15:51:34 2013
Succeeded at Thu Jan 17 15:51:34 2013 (Elapsed Time: 0.00 seconds)
Executing (Validate Topology): ValidateTopology C:\ClientData\Working\TestData\Test.gdb\FireRDs_Topo\FireRDs_Topology Full_Extent
Start Time: Thu Jan 17 15:51:34 2013
Succeeded at Thu Jan 17 15:51:34 2013 (Elapsed Time: 0.00 seconds)
Executing (Export Topology Errors): ExportTopologyErrors C:\ClientData\Working\TestData\Test.gdb\FireRDs_Topo\FireRDs_Topology C:\ClientData\Working\TestData\Test.gdb\FireRDs_Topo FireRDs_Topology
Start Time: Thu Jan 17 15:51:34 2013
Succeeded at Thu Jan 17 15:51:35 2013 (Elapsed Time: 1.00 seconds)
Succeeded at Thu Jan 17 15:51:36 2013 (Elapsed Time: 5.00 seconds)

The red color is the line that says it succeeds, but does not. The only difference between when I ran it first off was that I made the location a parameter.

Please help!

Outcomes