sista_kp84

Arcgis Engine 10.1 Attempted to read or write protected memory error.

Discussion created by sista_kp84 on Jan 15, 2013
Latest reply on Oct 2, 2014 by groyakkers
We are in process of upgrading our sde to 10.1 from 9.3.1. I have a Arcgis engine console application coverted to Arcgis 10.1. The exe runs itself runs fine when i run manually, but when i run as sql job it giving me following error.

"Unhandled Exception:System.AccessViolationException: Attempted to read or write protected memory. This is often an indication that other memory is corrupt. at ESRI.ArcGIS.esriSystem.AoInitializeClass.IsProductCodeAvailable(esriLicenseProductCode ProductCode) at LicenseInitializer.Initialize() "

According to my understanding we donot have to install arcgis engine developer kit on server. Arcgis engine application should be able to run using desktop license.

Server - Windows server 2008, Enterprise
ArcSDE - 64bit - SP1
Arcgis dekstop - sp1
SQL server 2008 R2

I Set the project to run under - x86 platform
Embed Interop Types - False.

Does anybody have a clue?

Thanks

Outcomes