radekpohl

geoprocessor message event not fired by ArcGIS for Server (10.0,win2008)

Discussion created by radekpohl on Dec 21, 2012
Anyone know what may I do to force geoprocessor to fire message events when running at ArcGIS server ? (10.0)

... tried different approaches using both ESRI.ArcGIS.Geoprocessor and newer ESRI.ArcGIS.Geoprocessing "geoprocessors" with no success - on desktop everything works like charm, however the same code executed on server results in no process messages thrown by geoprocessor - !but, all these messages are collected somewhere in the object and once model execution is done, these messages are accessible - of course, too late for me (we have to execute complicated, long running models and we do need inform user during model's execution what's actually happening :) )

what only I get on ArcGIS server are pre and post tool executing messages, so generally event firing works, with OnProcessMessages/GPMessage exception

I have tried almost everything, both sync and async execution, execution in new thread and asking geoprocessor and gpresult objects ... but no way, messages are ready only after model execution completed ...

thanks,
Radek

Outcomes