sungis

"no http answer" error when running geometry service

Discussion created by sungis on Dec 20, 2012
Latest reply on Jan 1, 2013 by MBranscomb-esristaff
I want to union all the features in the layer, but when running geometryService.UnionAsync, it causes an error "no http answer", I tried other services such as AreasAndLengthsAsync of the GeometryService but causes the same error. My codes are paste below, anyone can give me any suggestions? Thanks.


 LocalGeometryService.GetServiceAsync(localGeometryService =>
            {
                // Create a new GeometryService task instance.
                geometryTask = new GeometryService();

                // Set the Url property to the Url of the LocalGeometryService.
                geometryTask.Url = localGeometryService.UrlGeometryService;

                // Register event handlers for the BufferCompleted and Failed events.
                geometryTask.UnionCompleted += GeometryService_UnionCompleted;
                geometryTask.Failed += GeometryService_Failed;
            });

//after query and got all the features
void QueryTask_ExecuteCompleted(object sender, ESRI.ArcGIS.Client.Tasks.QueryEventArgs args)
        {
            FeatureSet featureSet = args.FeatureSet;

            selectedGraphics = featureSet.Features as List<Graphic>;
           //start union
           geometryTask.UnionAsync(selectedGraphics);
         }

Outcomes