ericmweber

ArcMap UI menus emptied by add-in

Discussion created by ericmweber on Dec 14, 2012
Latest reply on Dec 14, 2012 by sean_jones-esristaff
I have an add-in that is wreaking havoc occasionally on the ArcMap UI, and I don't know where to begin to look for the problem. After using the tools in the add-in for a while, toolbar buttons and tools other than the currently active tool cannot be selected. Menus (File, Edit, View, and so on) are empty. Right click a layer or right click in the data frame or right click on a file in Catalog, and the context menu is empty. Restarting ArcMap is the only way to get the UI back to normal operation.

When this problem occurs, the UI is not frozen or unresponsive. In fact a lot of things still work. For example, the current tool can still be used and functions as expected. Navigation in the data frame functions normally (though you have to use keyboard shortcuts to zoom, pan, etc., because you can't activate the zoom tool or pan tool by clicking the buttons in the toolbar). There is a dockable window associated with the add-in, and it behaves normally as well. Python window appears unaffected. Other than context menus being empty, Table of Contents, Catalog, and ArcToolbox seem to work normally.

The add-in is in ArcGIS 10.0. We haven't been able to uncover any pattern to when this occurs. There are only three of us using the add-in, all on different computers with different map documents and different data. The add-in is used for interactive editing of raster data. Does anyone know what might be causing these symptoms?

Thanks.

Outcomes