rhexter

CGA Bug: Parser broke and would not load script file

Discussion created by rhexter on Nov 6, 2012
Latest reply on Nov 6, 2012 by MBuehler-esristaff
So i had an interesting situation.
I was working away and altered a script. I closed city Engine to do some thing else and reopened it and was faced with an inability to open the script I was previously editing it just seem to kill the Parser before displaying the cga script in the editor.

I sat scratching my head for a bit with the parser not handling something nicely, I was unable to look for any line numbers for a stack trace. Outside of the editor I worked through the cga script to look at what I had been doing and took out chunks of shape steps bit by bit to narrow it down.

Interestingly I tracked this back to returning NIL from a Function that expected a string return.
So unlike Python you can't return NIL and expect it to behave like None and it looks like the cga Parser needs to handle that particular situation if it does already I'm unsure why the alteration of this one piece of code fixed it..

Outcomes