frqbatista

script works perfectly on 32bit windows, but not in 64bit

Discussion created by frqbatista on Oct 18, 2012
Latest reply on Oct 30, 2012 by frqbatista
I was developing a script to automate the production of a series of maps with the same base,
in which a loop selects a layer of a series and change its visibility from false to true and exports the map,
then moves on to the next layer . See here:


spp = ListLayers(mxd)

for layer in spp:
    if layer.visible == False:
                           
        layer.visible = True
        arcpy.ApplySymbologyFromLayer_management(layer, 'C:\\ProGEOtos\\anfibios\\modelo_EOO.lyr\\' )
     mxd.saveACopy(mappath +  layer.name + '.mxd')
        ExportToPDF(mxd, mappath + layer.name + '.pdf')
        print 'Created : ' +  layer.name + '.pdf'

        layer.visible = False

I worked out a script in my notbook 32-bit computer running windows 7 and it worked perfectly.
Then I tried to use it on another pc. that is 64-bit computer running windows 7. But it din't work.
I tried two more times on other different computers, all 64-bit windows 7, ArcGIS 10.0 and python 2.65.
Always returning the same error:

Runtime error <type 'exceptions.AttributeError'>: 'str' object has no attribute '_arc_object'

Does anybody can explain this or have a solution? Thanks a lot!

Outcomes