gnanicys

Disable the enabled security for GIS Services

Discussion created by gnanicys on Oct 4, 2012
Latest reply on Oct 9, 2012 by ciava.at
I realized that after enabling security for GIS services I am now required to enter in my windows log in and password to access the REST services page and even a bigger issue is that flex viewer can not see the rest services at all.  I have given myself permission and access rights to all services but still no luck.  So after careful consideration I decided to revert back to no security.  I followed these steps below.  In addition, to that I have applied Service pack5 to ALL products at 10.0 and have ran post install and restarted the machine twice.  Once after implementing the changes in the steps below and then once again after the service pack.  I have restarted SOC and SOM a couple times in between the changes as well, still no luck in seeing my rest services.  I just want things to be the way there were before I locked down the rest service directory.  Any ideas?



"Disabling security for services
Once you enable security for GIS services, you cannot use Manager to disable security. This is to prevent accidental disabling of security and compromise of access to your services. If you decide later that you must disable security, you can do so with the following steps.

Warning: If you perform these steps, any user will be able to connect to any GIS service using an Internet connection without providing any login.

1.Use a text editor (such as Notepad) or XML editor to open the file Server.dat on your server object manager (SOM) machine. This file is located in your ArcGIS Server installation at <ArcGIS Install Location>\server\system.
2.Change the following element, located inside the <Server> element, from
<SecurityEnabled>true</SecurityEnabled>
to
<SecurityEnabled>false</SecurityEnabled>
Then save the file.
3.Use a text or XML editor to open the file web.config in C:\Inetpub\wwwroot\ArcGIS\Services (adjust the path if you installed the ArcGIS Web services to a different location).
4.Locate the following line withing the <appSettings> section:
<add key="RequireToken" value="True" />
and change it to:
<add key="RequireToken" value="False" />
Then save the file.
5.Repeat the previous two steps for the web.config files in the Rest folder and also the Tokens folder in the C:\Inetpub\wwwroot\ArcGIS directory.
6.If security was configured for Windows users, then re-enable anonymous access to the Services and Rest folders in the ArcGIS Server Web instance in IIS. Refer to the instructions in the section on Disabling anonymous access to ArcGIS Web services in Internet Information Services, except in step 3 of the instructions, choose to enable anonymous access. Do this for both Services and Rest directories.
7.Restart the ArcGIS Server Object Manager service and the World Web Web Publishing Service. "

Outcomes