AnsweredAssumed Answered

WMTS for NASA

Question asked by flspat on Oct 4, 2012
Latest reply on Oct 4, 2012 by flspat
Hi All:

I'm trying to get a WMTS layer working for these new real time modis services from nasa.  After some initial fumbling with the sample, I have layer coming into the map but all I get are black tiles.  If I use the OpenLayers JavaScript API I get the expected layer images.  I used fiddler watch urls from both versions and the requests appear to be basically the same (different parameter ordering but that shouldn't matter) and the binary response also appears to be the same. 

Here's the test page:
ArcGIS JAPI: http://geo.gcs-holdings.net/nasawmts/default.aspx
OpenLayers: http://geo.gcs-holdings.net/nasawmts/openlayer/default.html


Here's the map init function: 

  function init() {               esri.config.defaults.io.proxyUrl = "proxy.ashx";               var map = new esri.Map("map", {                 wrapAround180: false             });               var layerInfo = new esri.layers.WMTSLayerInfo({                 identifier: "MODIS_Terra_CorrectedReflectance_TrueColor",                 tileMatrixSet: "EPSG4326_250m",                 format: "jpeg",                 style: ""             });               var options = {                 serviceMode: "KVP",                 layerInfo: layerInfo             };                  var wmtsLayer = new esri.layers.WMTSLayer("http://map1.vis.earthdata.nasa.gov/wmts-geo/wmts.cgi", options);               map.addLayer(wmtsLayer);           }


Thanks for any suggestions!

Outcomes