Why might WMS GetMap requiring LAYERS to be a number?

Discussion created by coreyalix01 on May 20, 2010
Latest reply on Apr 22, 2019 by Michael.Tonkel
I have a GET request which looks like this ("Hotspot" is a valid layer name):

GET /arcgis/services/SmallvilleOGC/MapServer/WMSServer?SERVICE=WMS&map=SmallvilleOGC&VERSION=1.1.1&REQUEST=GetMap&FORMAT=image/png&SRS=EPSG:4326&BBOX=-82.6,34.7,-82.2,35.1&WIDTH=1024&HEIGHT=1024&TRANSPARENT=TRUE&LAYERS=Hotspot&STYLES= HTTP/1.1

Which results in an exception:

<ServiceExceptionReport version="1.1.1">
  <ServiceException code="LayerNotDefined">
Parameter 'layers' contains unacceptable layer name.

As a guess I tried SmallvilleOGC:Hotspot but received the same error.  When I change LAYERS=0 it returns an image!

Any idea as to why this might be the case?  It really is named "Hotspot" so it doesn't appear to be a typo:

Data Type: File Geodatabase Feature Class
Location: D:\Map\smallville\calixville.gdb
Feature Dataset: CalixTest
Feature Class: Hotspot
Feature Type: Simple
Geometry Type: Polygon

Thanks for any help you can offer.