AnsweredAssumed Answered

The JTC connection file does not exist or could not be opened

Question asked by agaiser on Aug 27, 2012
Latest reply on Sep 17, 2012 by agaiser
I am trying to roll out ArcGIS Workflow Manager and Administrator to a specific machine and for some reason I cannot get either the Manager or the Administrator to work.

When the user starts WMX they get the error message:

The JTC connection file does not exist or could not be opened.

When the user starts WMX Adminstrator, the application opens, but when they double click the default connection they get the same error message.

I have confirmed that the DEFAULT_JTX_DB is set to the correct connection file.
I have confirmed the directory location of the Database folder using the WMXAdvancedSettings.exe.
I have confirmed that the .jtc file is indeed in that location (database folder).

I tried changing the Database folder to be in another location on the local drive to ensure that the user had read/write permissions, and then copied the .jtc file to that folder.

It still tells me the connection file does not exist.

I CAN open ArcCatalog on that machine and turn on the WMX extension and create a Workflow Manager Database connection without any problems. So I know that the user and login are file. In fact I create a new .jtc using ArcCatalog and I still get the error when opening Workflow Manager.

What am I missing? Any and all suggestions are appreciated.

Thanks!

Outcomes