KG22

Upgrading from 2.8 to 3.1

Discussion created by KG22 on Aug 15, 2012
Latest reply on Aug 15, 2012 by DSwingley-esristaff
My site breaks when i upgrade api versions from 2.8 to 3.1
I see many posts in here that error with esri not defined.
i don't think that is my issue and i have taken great pains to not reference esri.* outside of dojo.ready.
My issue is that the api does not appear to load properly, i never even hit dojo.ready.
When i have the 2.8 api I see files like this being loaded:

http://serverapi.arcgisonline.com/jsapi/arcgis/2.8/js/dojo/dojox/gfx/svg.xd.js

but when i have the 3.1 api these calls error out and i see it is trying to load that resource from here instead:

http://myserver.com/dojox/gfx/svg.js

Why would it be looking local to find this? it is doing likewise for jsapi_en-us.js and Dialog.jsa nd number.js
I get 6 or 7 errors on load.

Anybody seen this before?
Could it have anything to do with my module path:

  
<script type="text/javascript">djConfig = { parseOnLoad: true,usePlainJson: true, baseUrl: "", modulePaths: { "tg": "JGF/js/jg"}}</script>
    <script type="text/javascript" src="https://serverapi.arcgisonline.com/jsapi/arcgis/?v=3.1"></script>

Outcomes