njones623

Error When Creating TIN in Python

Discussion created by njones623 on Jul 25, 2012
Latest reply on Jul 29, 2012 by njones623
Hello,

I'm having trouble creating a tin in my Python script.  Everything looks right to me, but I keep getting the error:

<class 'arcgisscripting.ExecuteError'>: Failed to execute. Parameters are not valid.
ERROR 000800: The value is not a member of <None>.
ERROR 000800: The value is not a member of <None>.
ERROR 000800: The value is not a member of <None>.
ERROR 000800: The value is not a member of <None>.
Failed to execute (CreateTin)

There's one for every input in the TIN it appears.  I think it has something to do with the tag field, but I've tried a lot of things to get around this.  Here's the piece of my script:

arcpy.CreateTin_3d(InvertTIN,"PROJCS['NAD_1983_StatePlane_Georgia_West_FIPS_1002_Feet',GEOGCS['GCS_North_American_1983',DATUM['D_North_American_1983',SPHEROID['GRS_1980',6378137.0,298.257222101]],PRIMEM['Greenwich',0.0],UNIT['Degree',0.0174532925199433]],PROJECTION['Transverse_Mercator'],PARAMETER['False_Easting',2296583.333333333],PARAMETER['False_Northing',0.0],PARAMETER['Central_Meridian',-84.16666666666667],PARAMETER['Scale_Factor',0.9999],PARAMETER['Latitude_Of_Origin',30.0],UNIT['Foot_US',0.3048006096012192]]", \
                   "DownstreamPerpLineLeft3D Shape.Z hardline <None>; \
                    DownstreamPerpLineRight3D Shape.Z hardline <None>; \
                    UpstreamPerpLineLeft3D Shape.Z hardline <None>; \
                    UpstreamPerpLineRight3D Shape.Z hardline <None>","DELAUNAY")

Thanks,
Nick Jones

Outcomes