AnsweredAssumed Answered

Search Service: StartIndexing() failed

Question asked by krzychu on Jul 24, 2012
Latest reply on Jan 27, 2015 by piwaniukesri-pl-esridist
Hi,

I have a fresh installation of ArcGIS Server 10.1 (Current Version: 10.1.0, Current Build: 3035) and trying to run the Search Service.
I've registered sample folders with 12 different elements (tried different ways of sharing: server_name, localhost, IP ??? every of those were validated) and indexing status is still the same: Indexing, Items Indexed: 0.
First I tried to reinstall ArcGIS Server, also I checked different machine - the same result. I changed regional settings to US, but no change. I started to trace config files and finally switched the logging mode to debug.

There is an error StartIndexing() failed right after "Can not create CLSID_JItemIndex" and "Can not create CLSID_ItemIndex".

What is wrong with my configuration?

OS: Windows 7 64bit, ArcGIS Desktop 10.1 installed on the same machine. Default installation of ArcGIS Server (port 6080) without a Web adapter.


Part of Search.IndexGenerator log:

<Msg time='2012-07-24T11:38:30,737' type='DEBUG' code='5000' target='Utilities/Search.IndexGenerator' methodName='IndexGenerator.CreatorThreadFunc' machine='MyMachine' process='7024' thread='2388'  >Lock obtained. C:\arcgisserver\directories\arcgissystem\arcgisindex\Utilities\Search\cfg\generator.lck</Msg>
<Msg time='2012-07-24T11:38:30,752' type='DEBUG' code='5000' target='Utilities/Search.IndexGenerator' methodName='CIndexCreator.CreateIndex' machine='MyMachine' process='7024' thread='2388'  >Invoked.</Msg>
<Msg time='2012-07-24T11:38:30,782' type='DEBUG' code='5000' target='Utilities/Search.IndexGenerator' methodName='CIndexCreator.WriteIndex' machine='MyMachine' process='7024' thread='2388'  >12 xml files found in C:\arcgisserver\directories\arcgissystem\arcgisindex\Utilities\Search\Index\Staging</Msg>
<Msg time='2012-07-24T11:38:30,797' type='DEBUG' code='5000' target='Utilities/Search.IndexGenerator' methodName='CIndexCreator.StartIndexing' machine='MyMachine' process='7024' thread='2388'  >Invoked.</Msg>
<Msg time='2012-07-24T11:38:30,814' type='DEBUG' code='5000' target='Utilities/Search.IndexGenerator' methodName='CIndexCreator.StartIndexing' machine='MyMachine' process='7024' thread='2388'  >Can not create CLSID_JItemIndex.</Msg>
<Msg time='2012-07-24T11:38:30,831' type='DEBUG' code='5000' target='Utilities/Search.IndexGenerator' methodName='CIndexCreator.StartIndexing' machine='MyMachine' process='7024' thread='2388'  >Can not create CLSID_ItemIndex.</Msg>
<Msg time='2012-07-24T11:38:30,846' type='DEBUG' code='5000' target='Utilities/Search.IndexGenerator' methodName='CIndexCreator.WriteIndex' machine='MyMachine' process='7024' thread='2388'  >StartIndexing() failed.</Msg>
<Msg time='2012-07-24T11:38:30,862' type='DEBUG' code='5000' target='Utilities/Search.IndexGenerator' methodName='IndexGenerator.CreatorThreadFunc' machine='MyMachine' process='7024' thread='2388'  >Lock released. C:\arcgisserver\directories\arcgissystem\arcgisindex\Utilities\Search\cfg\generator.lck</Msg>

Regards, K.

Outcomes