AnsweredAssumed Answered

Having Problems with Creating/Publishing and Consuming mobile maps for iOS

Question asked by svancise2 on Jul 23, 2012
Latest reply on Jul 24, 2012 by svancise2
Hi,

I'm working with a team that is seeking to develop a custom GIS app based off of the ArcGIS mobile API for iOS. We are using ArcGIS for Server 10.1 and are having some issues with retrieving maps that have been published. So far we have been creating very simple maps to test the publishing and retrieving experience on an iPad.

At this time we have a map published with a single feature layer that we want to be able to display and edit within ArcGIS mobile for iOS and eventually do the same in our custom application. While we were publishing this map we enabled "Feature Access" as well as "Mobile Data Access." Once the map is published we tried to move it to the mobile content directory on our server. We used a simple JSON syntax that we found in various tutorials. Below is a sample of the syntax that we used. Of course, we replaced the url with one linking back to our server.
{    "version":"1.1",    "baseMap":{       "baseMapLayers":[          {             "url":"https://services.arcgisonline.com/ArcGIS/rest/services/ESRI_Imagery_World_2D/MapServer"          }       ],       "title":"Topography"    },    "operationalLayers":[       {          "url":"http://OurServer/ArcGIS/rest/services/Gas_Stations/MapServer",          "visibility":true,          "opacity":0.75,          "title":"Environmental Sensitivity"       }          ] }


We are able to see the map in ArcGIS Mobile on the iPad and when we open it the base map that we are pulling from esri is displayed but no features are displayed. In addition, when we go to the content tab within the app there is no content listed. We then tried to pull the map into our custom app to have similar results. I was hoping that someone would be able to give a bit of guidance or help.

Thanks!

Outcomes