rickjacks0nster123

(Re)Projecting UTM Oracle Spatial From Many Schemas To Lat/Long Single Schema

Discussion created by rickjacks0nster123 on May 12, 2010
Hi,

I am an Oracle DBA of many years, but a newcomer to Oracle Spatial.

My task is combining many Oracle schemas of spatial data in UTM, into a single schema of latitude/Longitude.  My GIS Analyst assisted me with the build of the single schema.  All MDSYS geom meta data table records are built for the features classes with the proper projection.

Data has been inserted into feature classes from many schemas into the single schema.  I used the SDO_CS.TRANSFORM while inserting data for the reprojection:  'SDO_CS.TRANSFORM(SHAPE,8307)'.  After data insertion and re-projection, I built the Oracle spatial index(es).  No problem.

Some data (feature classes) can be previewed with Oracle Map Builder or ArcCatalog. 

Other data will not render at all.  ArcCatalog gives me an error: 

The selected object failed to draw:
MY_SINGLESCHEMA.structure_existing_area:  Network I/O error

When I insert data into the single schema from only one schema, I can preview the Geometry with no problem.  Two or more schema data inserted into the single schema causes the above error in ArcCatalog.  Oracle Map Builder gives no error.  However, it fails to draw objects as well.

Also, my SDO_GEOM.VALIDATE_GEOMETRY_WITH_CONTEXT tells me there is no problem with the spatial data.

Now, why can't I see it???

Any help is greatly appreciated.

Rick

Outcomes