AnsweredAssumed Answered

10.1 - Instant crash on any (all?) spatial analyst tools.

Question asked by tmackey-esriaustralia-com-au-esridist on Jun 13, 2012
Latest reply on Jul 4, 2016 by poojakavisingh
FIXED - see below.

Hi all,

Just wondering if anyone's seen this before, and whether it's a quick fix.

I have installed the version of 10.1 released on Monday. However whenever I try to run any Spatial Analyst tools, ArcMap crashes.

For example, I open a new blank map document -> Raster Creation Toolset in SA toolbox -> Create Constant Raster -> Accept all default values (choose 1 for value) -> Hit "OK" -> Tool progress window appears for a split second, then Arcmap crashes with the error "ArcMap has encountered a serious application error and needs to close, do you want to report this to Esri".

If background processing is enabled, it crashes the background process, but ArcMap remains open. I tried wrapping the tool in a Python script, but the Python script crashes - a hard crash, "the python.exe process quit unexpectedly".

This also happens with other SA tools. Ones which I've tried include euclidean distance, extract by mask, and slope.

Not all raster operations seem to be broken - building pyramids works, Feature to Raster, Clip (from the Data Management\Raster toolset) & Project Raster all work. It seems to be limited to tools in the SA toolbox.

Whether the input or the output is in a geodatabase or folder, and if folder, what raster format I choose, makes no difference.

This is on Win7 x64.

A colleague can reproduce the same issues exactly on his machine. Same OS but different hardware. We installed 10.1 from media files which had been downloaded independently. My machine had 10.0 on it, but his machine had never had Esri software on it before (it was a brand new machine).

Is there something obvious I'm missing? I'm not crippled because I have a VM on which I was running the prerelease, which still works, so I can get things done. But I'm curious to hear if it's some quirk of my (and my colleagues') setup which we can resolve, or whether something happened between the prerelease and the gold master...

Thanks for your time.

[Edit to add - another one of my colleagues confirmed that they are experiencing the same issue.]