shaun_weston-eagle-co-nz-esridist

Geoprocessing Package Failing

Discussion created by shaun_weston-eagle-co-nz-esridist on Jun 10, 2012
Latest reply on Jul 11, 2012 by shaun_weston-eagle-co-nz-esridist
I've setup a geoprocessing package, which is a python script that exports an MXD to a PDF and finding that it crashes everytime with the following message:


{"error":{"code":500,"details":[],"message":"Unhandled Exception of unknown type in HandleHttpRequest: Worker process 'exportmap2_host' exited while attempting to service request (attempt 1 of 1): endpoint='GPServer' headers={} params={f=html, operation=execute, operationInput={  }, requestProperties={}} res='tasks/Test' post=0 Crash dump path=C:\\Users\\SWESTO~1.SPL\\AppData\\Local\\Temp\\ArcGISRuntimeErrorReports\\arcgisruntime_1.0.0.3057_service_20120611_001521.dmp"}}

The dump file then states:"The Thread tried to read from or write to a virtual address for which it does not have appropriate access"

When I use a gp package that is doing something like a buffer or an intersect, it works fine, however when running a script that creates a file it crashes?

I've tried debugging it using Process Monitor and can see RuntimeLocalServer accessing the file, but not exporting out the PDF. I understand this is Pre-release, so hoping it might run better when the final release is available.

Outcomes