AnsweredAssumed Answered

Error 99999: Ffailed to execute (contour) on SDE but not on FGDB

Question asked by kaspatoo on May 15, 2012
Latest reply on May 16, 2012 by kaspatoo
Hi,

I have a DEM Raster layer which I want to transfer to a contourlayer.
I tried the contour function from 3d analyst and spatial analyst as wess (guess they are still the same).
The Rasterdata lies in my SDE Database (and it shall stay there). I want to store the contour feature class also in this SDE. I am connected to the SDE through a SDE-service with sysadmin right on the database. Storeing data etc. else is no problem through this connection.

When saving the featureclass in a filegeodatabase it works fine. With the same parameters it fails after 5 seconds when chosing the SDE. It even does not start proceding (no percentage is shown), so I think its not a poblem of filesize. My raster also isnt that big. I also tried a contourintercall of 100 and 1000 instead of 1 (which works on FGDB) but no difference, just the nothing-saying-esri-standard-error. Oh and the feature class is stored in the sde-database but its empty.

PS: Why does ArcGIs not delete this featureclass? I would expect from a professional program to roll-back such failures.

Thanks.

Outcomes