minerjoe

Why won't an IAGSServerConnection work from IIS but will work from VS Server

Discussion created by minerjoe Champion on May 5, 2012
Latest reply on May 5, 2012 by minerjoe
I have a Rest service that needs to open an IAGSServerConnection.  When I run this from the Visual Studio application server or run it in a unit test harness everything works fine.  But if I try to run from IIS it will give me an error on the IAGSServerConnectionFactory::Open.

Access Denied:  Either the SOM service is not running or user is not a member fo the agsuser or agsadmin group....

For fun I tried adding user and password to the property set, but that has not impact.

In IIS I have done all the things that I have read need to be done to run ArcObjects.

Classic .NET AppPool is set to Integrated (I have tried both Classic and Integrated with same result) and I have Enable 32-bit applications set to true
My folder is an Application not a virtual directory
The application uses the Classic .NET AppPool

Can someone please explain what needs to change for a service to run from IIS that is different from it running in Visual Studio

Thanks
-Joe

Outcomes