Multiple tools fail: conversion "table to table"; extract multivalues to points; etc.

Discussion created by Stavvy on Mar 30, 2012
Latest reply on Apr 5, 2012 by cblinnmrc

I'm working with 7 large raster files representing environmental variables such elevation, slope, precipitation, etc. that have approximately 56 million cells. I need the output in a tabular format (.csv or .txt would work) where each row represents a different cell with its x,y coordinate and different environmental values. Then I have to load this data into R and use BIOMOD to run some species distribution models.

Here are some example rows:
gridcell1:       x       y        elevation       precipitation      slope          southwestness     etc.
gridcell2:       x       y        elevation       precipitation      slope          southwestness     etc.

So far I've been able to use the sample tool to create a .dbf file with all these values. Originally I had tried using the extract tool but it would simply fail or freeze up. Now I need to convert the .dbf to either a .txt or .csv file. I've tried to export it but that didn't complete. Only a portion the table was made before ArcMap failed. And I've also tried using the conversion tool "table to table" which has also failed each time I've tried it, although it will get about 20% finished.

I'm installing service pack 3 now to see if that might help although in the note about issues and critical fixes I don't see these problems addressed. I'm wondering if the initial .dbf file I made using the Sample tool might also be messed up. Or is there some sort of limit on how many rows ArcMap can handle? In advance, thanks for your assistance.

~Stavana Strutz

P.S. I'm running ArcMap 10 on a 64 bit Windows 7 machine that has 12 GB RAM and an Intel core i7 processor.