Bug in Point Statistics tool with PointZM Shapefiles?

Discussion created by mjgleaso on Mar 19, 2012
Latest reply on Mar 20, 2012 by mjgleaso
I'm trying to run the Point Statistics tool in Spatial Analyst on a PointZM shapefile. My goal is to calculate the STD of Z values within a specified search area. The options under the Field parameter include Shape.Z, but when I run the tool, I receive the following error:

ERROR 010123: Could not get field name.
Failed to execute (PointStatistics).

The documentation for the tool notes that the Field parameter "can be the Shape field if the input features contains z." So I've also tried to run it simply using Shape as the field name, and receive the same error. I've also tried the following unsuccessfully: enclosing Shape and Shape.Z in quotes, running the tool in Python, and running it on a file gdb feature class.

I've found one other post on this issue written in French on a non-ESRI site (http://www.forumsig.org/showthread.php?t=29232), but can't find anything else about it. My sense is this is a bug in the tool, but I just wanted to throw it out there in case anyone else has some ideas or ESRI support can help.

Just as a final note, the easy workaround of calculating a separate field for the Z values using Add XY Coordinates isn't really feasible in my case due to the size of the shapefile (it's LiDAR-derived). Calculating the Z values takes way too long for my workflow.