GP toolboxes won't load for multiple processes when executed at the same time

Discussion created by danielporter on Jan 27, 2012
Latest reply on Mar 2, 2012 by nmlebel
I'm using Arcgis 9.3.  Our license manager is located on our network, and we have a floating ArcINFO license.  I'm doing a CPU intensive operation on hundreds of files, so I'm using the Python 2.5 backport of the multiprocessing module to run several processes concurrently to speed things up.  I've got it working except for one thing.

When I make the child processes, they each are instructed to load the toolboxes.  Unfortunately, if I run things that simply (instantiate each process, let it load the toolbox), the toolboxes take forever to load (and may never load, but I haven't waited more than a couple of minutes).  The way I fixed it was by having the process "sleep" for variable periods of time (process one executes immediately, process two waits for 4 seconds...).  I'm guessing this is an issue with the license manager, but I'm not sure how to confirm that.

Has anyone else encountered this issue?  Do you know why it is, or another way to avoid it?