AnsweredAssumed Answered

featureserver usage issues

Question asked by DCSlatunn on Jan 9, 2012
Latest reply on Jan 20, 2012 by rnarayanan-esristaff
Hi, I am trying to use the new featureserver functionality in the REST api. I am trying to query, change some attributes, then applyEdits.  I have now been able to successfully query the featureserver, but am having issues applying edits.  After querying, I loop through the arguments and set Acres=2.   I then submit the following json call:


to delete:
mywebsite/FeatureServer/0/applyEdits?deletes=3,7&callback=ags_jsonp.ags_jsonp_16_681022&f=json

to update  (excuse the mess, it is a polygon with rings):
mywebsite/FeatureServer/0/applyEdits?updates=%5B%7Bgeometry%3A%5B%7Brings%3A%5B%5B%5B-83.37882840603902%2C43.79865258495296%5D%2C%5B-83.3788185084012%2C43.79934688161134%5D%2C%5B-83.37803627072316%2C43.79937341053053%5D%2C%5B-83.37800832323637%2C43.798669656223%5D%2C%5B-83.37882840603902%2C43.79865258495296%5D%2C%5B-83.37882840603902%2C43.79865258495296%5D%5D%5D%2C%20spatialReference%3A%7Bwkid%3A4326%7D%7D%5D%2C%20attributes%3A%7BOBJECTID%3A1%2C%20Acres%3A0%2C%207D%7D%5D&callback=ags_jsonp.ags_jsonp_18_893207&f=json

  Can anyone shed light on what I need to do to get this to work?  Do I need to use the "template" object in some way?  Does anyone see anything wrong with the http above?  I submit it with an expectation to receive a callback with "updateResults" arguments, but am not getting a successful callback at all...

Outcomes