khurram1805

App crashes when incorrect or incomplete Map layer loading from server

Discussion created by khurram1805 on Jan 3, 2012
Latest reply on Jan 23, 2012 by khurram1805
Hello, I am having a problem while loading map layer, problem is defined as below:

We had deployed our own local server and exposed different map layers services.
When there is some maintenance or updating is in progress at our local server.
During that time if we run the iPhone application which accesses our local server then application crashes. Where as application should activate the
"-(void) mapView:(AGSMapView *)mapView failedLoadingLayerForLayerView:(UIView<AGSLayerView> *)layerView withError:(NSError *)error"
or
"-(void) mapView:(AGSMapView *)mapView failedLoadingWithError:(NSError *)error"

events.

According to my understanding actually at server maintenance time when iPhone app tries to load the layer, at that time layer is not correct, so ArcGIS library thinks it to be correct and start doing its processing over that layer, so during that process some error occurs and app crashes. Once our servers are fully up and correct the same app runs perfect.

Secondly i think the error delegates which i mentioned above fired only when server is not available at all, or service is not found, or service is inaccessible, or connection lost, or network not available. But in my case everything is available but map layer itself not correct at server side. So it not handled in ArcGIS library and app crashes.

Can you please let me know is this is some known or unknown issue of ArcGIS library or i am missing something. I had seen this problem in old API as well as new 2.1 api as well.

Outcomes