wherewhy

AGSFindTask delegate not firing

Discussion created by wherewhy on Dec 19, 2011
Latest reply on Dec 21, 2011 by njarecha-esristaff
Hi
I have already done 2 implementations of AGSFindTask.
The delegate fires as expected.

On a third one, both in the existing viewController, and if I move it to its own viewController, the delegate will not fire.

In the header file, I've specified the delegate


#import <UIKit/UIKit.h>
#import "ArcGIS.h"


@interface TelemetryViewController : UIViewController  <UITableViewDelegate, UIPopoverControllerDelegate, AGSFindTaskDelegate>{
   
    UIPopoverController* _popOverController;
    UITableView *_tableView;

    AGSFindTask *_findTask;
    AGSFindParameters *_findParams;
   
}

@property (nonatomic,retain) UIPopoverController* popOverController;
@property (nonatomic, retain) IBOutlet UITableView *tableView;

@property (nonatomic, retain) AGSFindTask *findTask;
@property (nonatomic, retain) AGSFindParameters *findParams;

@end


----
In my function, I set up the query with hard-coded variables that I know work through testing the query in REST, and I've set the delegate to equal self.  But, the delegate :
-(void)findTask:(AGSFindTask *)findTask operation:(NSOperation *)op didExecuteWithFindResults:(NSArray *)results {


never fires!

----


//create find task and set the delegate
    self.findTask2 = [[AGSFindTask alloc] initWithURL:[NSURL URLWithString:self.baseLayerURL]];

    self.findTask.delegate = self;
  
    //create find task parameters
    self.findParams = [[AGSFindParameters alloc]init];
   
    //set find task parameters
    self.findParams.contains = NO;
    self.findParams.layerIds = [NSArray arrayWithObjects:[NSNumber numberWithInt:1],nil];
    self.findParams.outSpatialReference = self.mapView.spatialReference;
    self.findParams.returnGeometry = TRUE;
    self.findParams.searchFields = [NSArray arrayWithObjects:@"FTPID",nil];
  
   
    self.findParams.searchText = @"WTK001";
   
    //execute find task
    [self.findTask executeWithParameters:self.findParams];

--------
Has anyone else experienced this or have any idea what could be causing this?
I've checked the other forum posts on the idea and I've made sure I have the delegate in the header file and the delegate set to self in the implementation file.

Thanks

Outcomes