AnsweredAssumed Answered

extract by mask fails - possibly corrupting original source raster

Question asked by jkvreeland on Dec 8, 2011
Latest reply on Feb 18, 2016 by curtvprice
Arc10 is failing to execute extract by mask...sometimes and more recently all the time. Never had this problem before 10, and error codes not helpful.

Using original land use-land cover, 8-bit, discrete, unsigned integer, GRID raster with colormap. This raster covered state of PA. Years ago, I did a majority filter twice and extracted a smaller area I work in - about 10,000 sq mi.

I regularly need to extract smaller landscapes - a few tens of square miles. My masks are shapefiles.

A couple of days ago, I performed an extract successfully, but I misnamed the output file and put it in a bad location, and because catalogue never lets me rename rasters I create (!), I decided to delete it and rerun the extract.

Well, it hasn't worked since except one time when I "re-ran" the analysis in the results window from that session. I've tried the operation on different computers with the same source data, tried rebooting, rerunning the original extract. What I found was extracts from the original data and my statewide majority filter were working until today. Now extract won't work at all as if it's corrupting my source data.

The source raster for the LULC is discrete and the colormap is present, but any time I extract a smaller piece of it, the source becomes continuous and the colormap is absent.

I found some tools to modify these features in "properties" for the new, extracted rasters: add colormap, change  change to discrete, but even though no errors show when I run these, the properties aren???t changed, particularly the discrete/continuous.

Even when the extract procedure doesn???t work, it often will still create a grayscale raster, but sometimes it doesn???t. Sometimes it creates spatial reference info and sometimes it doesn???t.

I have no idea what's going on and am not a proficient user of rasters enough to know what could be wrong.

Can anyone help?

thanks,
frustrated in PA!!!

Outcomes