pstrbenac

pyproj.4 Runntime Error - k <= 0 Failed to execute

Discussion created by pstrbenac on Dec 2, 2011
I wrote a python script that uses pyproj.4 library (latest version) for cartographic projections (http://trac.osgeo.org/proj/). When I run the script from Arc Map (directly from toolbox) everything works fine and script executes successfully. However if I publish it using ArcGIS Server as a geoprocessing service and run it as a service (on the same machine) I get error "Runntime Error - k <= 0 Failed to execute". I was searching for some feedback on forums and found that it might have something to do with regional settings and decimal separator (http://code.google.com/p/pyproj/issues/detail?id=16). My first regional settings was Croatian with comma "," as decimal separator. With this setting I couldn't run script successfully from ArcMap. Then I just changed decimal separator to "." and now it works from ArcMap but it doesn't work if I run it as a service. What is the difference in executing script directly from toolbox and executing it as a service? Does anyone know how to make it work either way?

Outcomes