FlexViewer 2.4 strange error #2032

Discussion created by mapsrgr8 on Oct 6, 2011
Latest reply on Mar 2, 2012 by xylochic627
This error has been driving me crazy for days now. I've tried mining the web and the Esri forums for any information that would help me rectify/diagnose the error. Tried everything out there, still with no luck. It's not a cross domain issue. The server, map services, and I am all on the same domain. It's not a MIME types issue or a mixing of IP addresses with machine names issue. It occurs randomly at least once a day, doesn't matter which web browser is used (IE, FF) usually at the first instance the server has to "spin up" per user invoke and serve the data in the morning, and it seems to be affecting random map services (of which there are 8). Here is the actual error message:

County_Cities layer failed to load: Fault code: Server.Error.Request

Fault info: HTTP request error

Fault details: Error: [IOErrorEvent type="ioError" bubbles=false cancelable=false eventPhase=2 text="Error #2032: Stream Error. URL: http://gis01/ArcGIS/rest/services/XXXXXX/County_Cities/MapServer?f=json"]. URL: http://gis01/ArcGIS/rest/services/XXXXXX/County_Cities/MapServer?f=json

Here are the server specs:
Running Windows Server 2003, Standard Edition, SP2
IIS Version 6
ASP.Net Version 2.0.50727

I've adjusted the "Periodically check and repair data connections for idle instances" inside Manager for all the operational layers, changing the defualt setting from 30 to 15 minutes, then inside the server, I changed the settings for the ArcGIS ServicesAppPool Properties, under the performance tab for idle timeouts to 30 minutes and enabled pinging every 30 minutes. That still did not solve the issue.

Here is a an example of the mapservice URL contained within my project's config.xml file:
<layer label="County - Cities" type="dynamic" alpha="0.5" visible="true"

the application was buillt with Adobe Flash Builder 4.5 and the Flex 4.5 SDK. Have Flash Player 10.3
installed, my compiler arguments are as follows: -locale en_US -source-path=locale/{locale} -keep-all-type-selectors=true

I've tried moving the operational layers into the pre-compiled Flex Viewer 2.4 just to test and see if it was something to do with the way I was compiling, but the same error occurs with the pre-compiled version as well, which is leading me to believe that it's something to do with the IIS or Server Configuration.

I am stumped. Has anyone else battled this error with any success? If so, please share your solution and chime in with further diagnostics for me to troubleshoot. Any and all help here is much appreciated.