onei0125

arcpy.mapping exportToJPG/exportToPDF does not display the table in my layout

Discussion created by onei0125 on Oct 5, 2011
Latest reply on Oct 6, 2011 by onei0125
Good afternoon,

I have been working on a script to export multiple data driven pages including a table that updates based on a definition query.  I have added information from an attribute table using "Add table to layout.  According to a blog I read this table should update automatically based on any changes made to the attribute table. http://blogs.esri.com/Support/blogs/mappingcenter/archive/2010/01/18/Using-Tables-in-an-ArcMap-Layout.aspx  My first problem, is in order to get the table to update in the layout I have to open and close the properties before I see the changes.  Also, I have to re-add the table each time I open ArcMap to get it to establish the link to the source table (otherwise the table is empty).  These are minor annoyances, but the biggest issue I have is that when I export pages one of two things happens:
1. If I export a single page PDF from the layout in ArcMap, the table in the PDF has no boundary or column lines; exporting as a single page JPEG seems to work okay
2. If I export multiple pages using a Python script, the table does not appear at all no matter what file format I use

I would like to resolve some of these issues so that I can export multiple pages at once via Python and still maintain the appearance of the layout, i.e. the table needs to show up.

Has anyone had any success dealing with similar issues?  I am looking into other options to incorporate a dynamic table into my layout, but I would still like to know what's causing these problems.

Thanks,
Shawn O.
GIS Tech

Outcomes