murdburg

Average Nearest Neighbor tool not detecting randomness? (ArcGIS 10.0 bug?)

Discussion created by murdburg on Sep 28, 2011
Latest reply on Apr 20, 2012 by jevans02
Hello,

I have started to play with the Spatial Statistics toolbox using three shape files:

1) Evenly-spaced point data (generated from Create Fishnet tool)
2) Random point data (generated from Create Random Points tool)
3) Real-world point data (results of research in Australia)

The outputs of (1) and (2) are rectangular in extent, constrained by the extent of my Australia (3) shapefile. I ran the Average Nearest Neighbor tool on all three datasets and received the expected results (based on visual examination):

1) Dispersed (with associated p-values and z-scores)
2) Random (ditto)
3) Clustered (ditto)

Next, I clipped (1) and (2) by the actual outline of Australia (3) and re-ran the first two analyses. This is where I noticed an interesting - but troubling - problem:

1) Dispersed (no problem)
2) Clustered (?!?)

The clipped dataset contains ~80% of the original points, each in their original, random location (on terrestrial Australia). Thus, they should still output as Random, but they output as Clustered.

I have replicated this problem using multiple shapefiles of random points. In each case of using the Average Nearest Neighbor tool, the full rectangle of random points gives a result of Random but clipping out the middle of the rectangle gives a result of Clustered. I have also created shapefiles of random points using the Constraining Feature Class (versus the Constraining Extent) option and achieved the same result (Clustered).

I'm hoping to understand why this would happen in order to understand the results of more advanced analyses (such as Ripley's K and Moran's I). Anyone have any ideas about this problem? Cheers,

Chris

Outcomes