InsaneLane

processArcPadProject_ArcPad ERROR 999998

Discussion created by InsaneLane on Sep 19, 2011
Latest reply on Sep 19, 2011 by InsaneLane
My python script for processing ArcPad Projects is failing with an error 999998.  Is this common?

I'm using the script that is exported from the model builder and after the last line it fails:

    gp.ProcessArcPadProject_ArcPad(THEMAP_mxd, "true")

Each time I run the script, it seems to process correctly (output arcpad project looks okay) but the script ends with "Failed to execute (ProcessArcPadProject)" and "arcgisscripting.ExecuteError: ERROR 999998: There are no more files."

I have tried several MXD files as the source using shape files for data in the mxd and axf and shapefiles as the output, edit or read only.  Some of the test MXDs were very simple just to try to debug this issue.

We are currently on ArcMap 9.3.1 w/ SP1

I have tried several MXD files as the source for the processArcPadProject_ArcPad procedure.

The manual Get Data for ArcPad tool in ArcMap runs successfully.  The model using processArcPadProject_ArcPad seems to work fine with no errors.  In some cases the output ArcPad project seems to look complete; other times it looks incomplete (missing apm and other files).  I worry with an error message like this I shouldn't use the output.

Anyone else have experience with python and the processArcPadProject_ArcPad procedure and that don't get this error?

Outcomes