gsumerlingesriaustralia-com-au-esridist

IOS V2 dies on service that works on 1.8.5

Discussion created by gsumerlingesriaustralia-com-au-esridist Employee on Jul 14, 2011
Latest reply on Jul 18, 2011 by njarecha-esristaff
Hello,

I have a local ArcGIS server which the IOS application connects to under 1.8.5. I am able to edit and display features. I have upgrade the ipad to V 2.0 and now when I connect to this service it simply exits the application. The JSON for this is as follows:

{
"version": 1.1,
"operationalLayers":[{
{"opacity": 1, "url":"http://192.168.1.2/ArcGIS/rest/services/Mobile/Adelaide_City_Mobile_tree_photo/FeatureServer/5",
"visibility": true,
"mode": 1,
"title": "Inspection Area"
}
],
"baseMap":{
"baseMapLayers":[
{"opacity": 1, "url":"http://192.168.1.2/ArcGIS/rest/services/Mobile/Adelaide_City_Image/MapServer",
"visibility": true
}],
"title":"Adelaide Image"}

I tried to update the JSON to match a similar configured collection sample on ArcGIS online. This included pou-ups. But this gives the error: "The map is invalid and cannot be opened". The Json for this updated service is:
{
"version": 1.2,
"operationalLayers":[{"opacity": 1, "url":"http://192.168.1.2/ArcGIS/rest/services/Mobile/Adelaide_City_Mobile_tree_photo/FeatureServer/5",
"id": "INSPECTION_AREA",
"visibility": true,
"mode": 1,
"title": "Inspection Area",
"popupInfo": {
    "title": "Inspection Area: {inspector}",
"fieldInfos": [
  {
            "fieldName": "objectid",
            "label": "Objectid",
            "isEditable": false,
            "tooltip": "",
            "visible": false,
            "format": null,
            "stringFieldOption": "textbox"
          },
          {
            "fieldName": "INSPECTOR",
            "label": "Field Inspector",
            "isEditable": true,
            "tooltip": "Select Field Inspector",
            "visible": true,
            "format": null,
            "stringFieldOption": "textbox"
          },
    {
            "fieldName": "INSPECTION_COMPLETE",
            "label": "Inspection Complete",
            "isEditable": true,
            "tooltip": "",
            "visible": true,
            "format": null,
            "stringFieldOption": "textbox"
          },
    {
            "fieldName": "INSPECTION_DATE",
            "label": "Date Complete",
            "isEditable": true,
            "tooltip": "",
            "visible": true,
            "format": {"dateFormat": "shortDateShortTime"},
            "stringFieldOption": "textbox"
          },
       {
            "fieldName": "globalid",
            "label": "GlobalID",
            "isEditable": false,
            "tooltip": "",
            "visible": false,
            "format": null,
            "stringFieldOption": "textbox"
          }
        ],
        "description": null,
        "showAttachments": false,
        "mediaInfos": []
     
}}
],
"baseMap": {
    "baseMapLayers": [{"opacity": 1, "url":"http://192.168.1.2/ArcGIS/rest/services/Mobile/Adelaide_City_Image/MapServer",
"visibility": true
}],
"title": "BaseMap"
},
}

Any thoughts on why the V2.0 app does not work with my services?

Regards
Gordon

Outcomes