sergiy2001

Copy_management layer with raster field

Discussion created by sergiy2001 on Jul 14, 2011
I have a problem to copy dataset with layer that have a raster field.
import arcgisscripting
arcpy = arcgisscripting.create()
arcpy.SetProduct("ArcInfo")
arcpy.AddToolbox("C:\\Program Files (x86)\\ArcGIS\\Desktop10.0\\ArcToolbox\\Toolboxes\\Data Management Tools.tbx")
asys_SDE_address_plan = "Database Connections\\Connection to 10.0.16.139_asys_sde.sde\\asys.SDE.address_plan"
asys_SDE_address_plan203 = "Database Connections\\Connection to 10.0.1.203_asys_win.sde\\asys.SDE.address_plan"
arcpy.Copy_management(asys_SDE_address_plan203, asys_SDE_address_plan, "FeatureDataset")

It's allways return strange error:

PythonWin 2.6.5 (r265:79096, Mar 19 2010, 21:48:26) [MSC v.1500 32 bit (Intel)] on win32.
Portions Copyright 1994-2008 Mark Hammond - see 'Help/About PythonWin' for further copyright information.
Traceback (most recent call last):
  File "C:\Python26\ArcGIS10.0\Lib\site-packages\Pythonwin\pywin\framework\scriptutils.py", line 307, in RunScript
    debugger.run(codeObject, __main__.__dict__, start_stepping=1)
  File "C:\Python26\ArcGIS10.0\Lib\site-packages\Pythonwin\pywin\debugger\__init__.py", line 60, in run
    _GetCurrentDebugger().run(cmd, globals,locals, start_stepping)
  File "C:\Python26\ArcGIS10.0\Lib\site-packages\Pythonwin\pywin\debugger\debugger.py", line 624, in run
    exec cmd in globals, locals
  File "D:\New\asys_replication.py", line 126, in <module>
    arcpy.Copy_management(asys_SDE_dep_transport203, asys_SDE_dep_transport, "FeatureDataset")
  File "D:\New\asys_replication.py", line 126, in <module>
    arcpy.Copy_management(asys_SDE_dep_transport203, asys_SDE_dep_transport, "FeatureDataset")
  File "C:\Python26\ArcGIS10.0\lib\bdb.py", line 46, in trace_dispatch
    return self.dispatch_line(frame)
  File "C:\Python26\ArcGIS10.0\lib\bdb.py", line 64, in dispatch_line
    self.user_line(frame)
  File "C:\Python26\ArcGIS10.0\Lib\site-packages\Pythonwin\pywin\debugger\debugger.py", line 585, in user_line
    debugger_parent.user_line(self, frame)
  File "C:\Python26\ArcGIS10.0\lib\pdb.py", line 150, in user_line
    self.interaction(frame, None)
  File "C:\Python26\ArcGIS10.0\lib\pdb.py", line 194, in interaction
    self.cmdloop()
  File "C:\Python26\ArcGIS10.0\Lib\site-packages\Pythonwin\pywin\debugger\debugger.py", line 562, in cmdloop
    self.GUIAboutToBreak()
  File "C:\Python26\ArcGIS10.0\Lib\site-packages\Pythonwin\pywin\debugger\debugger.py", line 815, in GUIAboutToBreak
    self.GUIAboutToInteract()
  File "C:\Python26\ArcGIS10.0\Lib\site-packages\Pythonwin\pywin\debugger\debugger.py", line 833, in GUIAboutToInteract
    fw = win32ui.GetForegroundWindow()
error: No window is is in the foreground.

after I check dataset and I see that all layers were copied except layer with raster field. I think raster field is a "bad guy"
help me please...

Outcomes